blob: e29abb3e31345473a7c67e1702afabab5458f749 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A simple, sane and efficient module to slurp a file"
2DESCRIPTION = "This module provides functions for fast and correct slurping and spewing. \
3All functions are optionally exported. All functions throw exceptions on \
4errors, write functions don't return any meaningful value."
5
6SECTION = "libs"
7LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
8
9HOMEPAGE= "https://metacpan.org/release/File-Slurper"
10
11LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
12file://${COMMON_LICENSE_DIR}/GPL-1.0-or-later;md5=30c0b8a5048cc2f4be5ff15ef0d8cf61"
13
14SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/File-Slurper-${PV}.tar.gz"
15
16SRC_URI[sha256sum] = "d5a36487339888c3cd758e648160ee1d70eb4153cacbaff57846dbcefb344b0c"
17RDEPENDS:${PN} = " \
18 perl-module-carp \
19 perl-module-encode \
20 perl-module-exporter \
21 perl-module-perlio \
22 perl-module-perlio-encoding \
23 perl-module-strict \
24 perl-module-warnings \
25"
26
27RDEPENDS:${PN}-ptest += "libtest-warnings-perl \
28 perl-module-test-more \
29 "
30
31S = "${WORKDIR}/File-Slurper-${PV}"
32
33inherit cpan ptest-perl
34
35BBCLASSEXTEND = "native"