blob: a3d9ceef0238cc742d0cedc0c40b0545ca690df5 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "MIME::Types - Definition of MIME types"
2DESCRIPTION = "MIME types are used in MIME compliant lines, for instance \
3as part of e-mail and HTTP traffic, to indicate the type of content which \
4is transmitted. Sometimes real knowledge about a mime-type is need.\
5\n\
6This module maintains a set of MIME::Type objects, which each describe \
7one known mime type."
8HOMEPAGE = "http://search.cpan.org/~markov/MIME-Types-${PV}"
9SECTION = "libraries"
10
11LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
12LIC_FILES_CHKSUM = "file://META.yml;beginline=11;endline=11;md5=963ce28228347875ace682de56eef8e8"
13
14SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/MIME-Types-${PV}.tar.gz \
15 file://run-ptest \
16 "
17SRC_URI[sha256sum] = "629e361f22b220be50c2da7354e23c0451757709a03c25a22f3160edb94cb65f"
18
19S = "${WORKDIR}/MIME-Types-${PV}"
20
21inherit cpan ptest
22
23RDEPENDS:${PN} = "\
24 perl-module-base \
25 perl-module-carp \
26 perl-module-constant \
27 perl-module-cwd \
28 perl-module-encode-encoding \
29 perl-module-file-basename \
30 perl-module-file-spec \
31 perl-module-list-util \
32 perl-module-overload \
33 perl-module-perlio \
34 perl-module-perlio-encoding \
35"
36
37RDEPENDS:${PN}-ptest = "\
38 perl-module-lib \
39 perl-module-test-more \
40"
41
42#RSUGGESTS:${PN}-ptest = "libmojo-base-perl"
43
44do_install_ptest () {
45 cp -r ${B}/t ${D}${PTEST_PATH}
46}