blob: 7c7753034be38d80b55af4e6d638e50e92cc3e18 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The asttokens module annotates Python abstract syntax trees (ASTs)"
2HOMEPAGE = "https://github.com/gristlabs/asttokens"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
5
6PYPI_PACKAGE = "asttokens"
7
8inherit pypi python_setuptools_build_meta
9
10SRC_URI[sha256sum] = "4622110b2a6f30b77e1473affaa97e711bc2f07d3f10848420ff1898edbe94f3"
11
12DEPENDS += "python3-setuptools-scm-native"
13
14RDEPENDS:${PN} += " \
15 ${PYTHON_PN}-six \
16"
17
18BBCLASSEXTEND = "native"