blob: d61189bfdf8d72a9456fc2ac09e4d675a12d371f [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Provides modules to easily parse localized dates in almost any string formats commonly found on web pages"
2HOMEPAGE = "https://github.com/scrapinghub/dateparser"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3d3ed25571191e7aa3f55d0a6efe0051"
5
6SRC_URI[sha256sum] = "107f3cc87a60770e10d111349adc1504224a6b60753a47a64b0ec842ab85b5a9"
7
8PYPI_PACKAGE = "dateparser"
9
10inherit pypi setuptools3
11
12CLEANBROKEN = "1"
13
14RDEPENDS:${PN} += " \
15 ${PYTHON_PN}-dateutil \
16 ${PYTHON_PN}-tzlocal \
17 ${PYTHON_PN}-ruamel-yaml \
18"
19
20# Ommitted ${PYTHON_PN}-convertdate, ${PYTHON_PN}-jdatetime ${PYTHON_PN}-umalqurra