blob: 84356cf6fd67dbb947426d19934a138c87cd4091 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Convert GeoJSON to WKT/WKB (Well-Known Text/Binary), and vice versa."
2DESCRIPTION = "Convert GeoJSON to WKT/WKB (Well-Known Text/Binary), and vice versa."
3HOMEPAGE = "https://github.com/geomet/geomet"
4SECTION = "devel/python"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
7SRCNAME = "geomet"
8
9SRC_URI[sha256sum] = "cb52411978ee01ff104ab48f108d7333b14423ae7a15a65fee25b7d29bda2e1b"
10
11S = "${WORKDIR}/git"
12SRC_URI = "git://github.com/geomet/geomet.git;protocol=https;branch=master"
13SRCREV = "7fff4438510c30e592db858b2d519eddb5837a6c"
14
15inherit setuptools3
16PIP_INSTALL_PACKAGE = "geomet"
17
18RDEPENDS:${PN} += "\
19 ${PYTHON_PN}-click \
20 ${PYTHON_PN}-core \
21 ${PYTHON_PN}-io \
22 ${PYTHON_PN}-json \
23 ${PYTHON_PN}-logging \
24 ${PYTHON_PN}-six \
25"