blob: 439358d05f84f1542411816a22a92ba4b6a8541a [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Google API client core library"
2HOMEPAGE = "https://github.com/googleapis/python-api-core"
3AUTHOR = "Google LLC"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7inherit pypi setuptools3
8
9SRC_URI[sha256sum] = "4b9bb5d5a380a0befa0573b302651b8a9a89262c1730e37bf423cec511804c22"
10
11RDEPENDS:${PN} += "\
12 ${PYTHON_PN}-asyncio \
13 ${PYTHON_PN}-datetime \
14 ${PYTHON_PN}-logging \
15 ${PYTHON_PN}-math \
16"
17
18RDEPENDS:${PN} += "\
19 ${PYTHON_PN}-googleapis-common-protos \
20 ${PYTHON_PN}-google-auth \
21 ${PYTHON_PN}-grpcio \
22 ${PYTHON_PN}-protobuf \
23 ${PYTHON_PN}-pytz \
24 ${PYTHON_PN}-requests \
25 ${PYTHON_PN}-six \
26"