blob: 3ece22c38257738587c9a6d20465177c9e032636 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A Python utility / library to sort Python imports."
2HOMEPAGE = "https://pypi.python.org/pypi/isort"
3LICENSE = "MIT"
4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=6;endline=6;md5=8227180126797a0148f94f483f3e1489"
6
7SRC_URI[sha256sum] = "6db30c5ded9815d813932c04c2f85a360bcdd35fed496f4d8f35495ef0a261b6"
8
9inherit pypi python_poetry_core
10
11RDEPENDS:${PN} += "\
12 ${PYTHON_PN}-datetime \
13 ${PYTHON_PN}-shell \
14 ${PYTHON_PN}-profile \
15 ${PYTHON_PN}-numbers \
16 ${PYTHON_PN}-pprint \
17 ${PYTHON_PN}-difflib \
18"
19
20BBCLASSEXTEND = "native nativesdk"