blob: 71171513e8a43a6cc9130599c65bf178d14cc4bc [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "python bindings for the lz4 compression library by Yann Collet"
2
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=6231efa4dd4811e62407314d90a57573"
5
6DEPENDS += " \
7 lz4 \
8 ${PYTHON_PN}-setuptools-scm-native \
9 ${PYTHON_PN}-pkgconfig-native \
10"
11
12SRC_URI += "file://run-ptest"
13
14SRC_URI[sha256sum] = "e1431d84a9cfb23e6773e72078ce8e65cad6745816d4cbf9ae67da5ea419acda"
15
16inherit pkgconfig pypi python_setuptools_build_meta ptest
17
18RDEPENDS:${PN}-ptest += "${PYTHON_PN}-pytest ${PYTHON_PN}-multiprocessing ${PYTHON_PN}-psutil"
19
20do_install_ptest() {
21 cp -rf ${S}/tests/ ${D}${PTEST_PATH}/
22 # The stream API is experimental and not enabled yet, so don't ship the test suite
23 rm -rf ${D}${PTEST_PATH}/tests/stream
24}
25
26BBCLASSEXTEND = "native nativesdk"