blob: 91f6462b3592ff0a24af12a2123543b014366c9a [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Simplified object serialization in python"
2DESCRIPTION = "Marshmallow is an ORM/ODM/framework-agnostic library for converting complex datatypes, such as objects, to and from native Python datatypes."
3AUTHOR = "Marius Kriegerowski <mk@quakesaver.net>"
4HOMEPAGE = "https://github.com/marshmallow-code/marshmallow"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "\
7 file://LICENSE;md5=5bccd400dedfa74364481e56aacc0b4a \
8 file://docs/license.rst;md5=13da439ad060419fb7cf364523017cfb"
9
10SRC_URI = "git://github.com/marshmallow-code/marshmallow.git;protocol=https;branch=dev"
11
12SRCREV = "78edf5582ee325bba99f097cb7167ef73b6f84d8"
13
14S = "${WORKDIR}/git"
15
16inherit setuptools3
17
18PIP_INSTALL_PACKAGE = "marshmallow"
19
20RDEPENDS:${PN} += " \
21 python3-core \
22 python3-datetime \
23 python3-netclient \
24 python3-numbers \
25 python3-json \
26 python3-pprint \
27 python3-packaging \
28"