blob: 92883f3198c763da2a46bc7c7d3297823d4cb1c2 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Python package for creating and manipulating graphs and networks"
2HOMEPAGE = "http://networkx.github.io/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=44614b6df7cf3c19be69d0a945e29904"
5
6SRC_URI[sha256sum] = "230d388117af870fce5647a3c52401fcf753e94720e6ea6b4197a5355648885e"
7
8inherit pypi setuptools3
9
10RDEPENDS:${PN} += "\
11 ${PYTHON_PN}-decorator \
12 ${PYTHON_PN}-netclient \
13 ${PYTHON_PN}-compression \
14 ${PYTHON_PN}-numbers \
15 ${PYTHON_PN}-pickle \
16 ${PYTHON_PN}-html \
17 ${PYTHON_PN}-xml \
18 ${PYTHON_PN}-json \
19 ${PYTHON_PN}-profile \
20 ${PYTHON_PN}-threading \
21 "