blob: 403a987d1e5d20e52249a71cc8f2ff73df1da4a6 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \
2Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
3Contributors."
4HOMEPAGE = "https://pillow.readthedocs.io"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=bc416d18f294943285560364be7cbec1"
7
8SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=main;protocol=https \
9 file://0001-support-cross-compiling.patch \
10 file://0001-explicitly-set-compile-options.patch \
11 "
12SRCREV ?= "82541b6dec8452cb612067fcebba1c5a1a2bfdc8"
13
14inherit setuptools3
15
16PIP_INSTALL_PACKAGE = "Pillow"
17PIP_INSTALL_DIST_PATH = "${S}/dist"
18
19DEPENDS += " \
20 zlib \
21 jpeg \
22 tiff \
23 freetype \
24 lcms \
25 openjpeg \
26"
27
28RDEPENDS:${PN} += " \
29 ${PYTHON_PN}-misc \
30 ${PYTHON_PN}-logging \
31 ${PYTHON_PN}-numbers \
32"
33
34CVE_PRODUCT = "pillow"
35
36S = "${WORKDIR}/git"
37
38RPROVIDES:${PN} += "python3-imaging"
39
40BBCLASSEXTEND = "native"
41
42SRCREV = "a5bbab1c1e63b439de191ef2040173713b26d2da"