blob: f5223913cfe43b5a506c0f1ca79fb4354481244f [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Python interface for c-ares"
2DESCRIPTION = "\
3pycares is a Python module which provides an interface to c-ares. c-ares is \
4a C library that performs DNS requests and name resolutions asynchronously."
5HOMEPAGE = "https://github.com/saghul/pycares"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=b1538fcaea82ebf2313ed648b96c69b1"
8
9SRC_URI[sha256sum] = "c542696f6dac978e9d99192384745a65f80a7d9450501151e4a7563e06010d45"
10
11PYPI_PACKAGE = "pycares"
12
13inherit pypi setuptools3
14
15DEPENDS += "${PYTHON_PN}-cffi-native"
16
17RDEPENDS:${PN} += " \
18 ${PYTHON_PN}-cffi \
19 ${PYTHON_PN}-idna \
20"