blob: b4680e35d3675f8a01a8fb54352af579f23dccc8 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Python API for MISP"
2HOMEPAGE = "https://github.com/MISP/PyMISP"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a3639cf5780f71b125d3e9d1dc127c20"
5
6SRC_URI = "git://github.com/MISP/PyMISP.git;protocol=https;branch=main"
7SRCREV = "29dc2d6d1aa7919f50db256525bf66aa52b585ec"
8S = "${WORKDIR}/git"
9
10inherit python_poetry_core
11
12PIP_INSTALL_PACKAGE = "pymisp"
13
14RDEPENDS:${PN} += " \
15 ${PYTHON_PN}-dateutil \
16 ${PYTHON_PN}-json \
17 ${PYTHON_PN}-jsonschema \
18 ${PYTHON_PN}-requests \
19 ${PYTHON_PN}-six \
20 ${PYTHON_PN}-deprecated \
21 ${PYTHON_PN}-wrapt \
22"
23
24# Fixes: python3-pymisp requires /bin/bash, but no
25# providers found in RDEPENDS:python3-pymisp? [file-rdep]
26RDEPENDS:${PN} += "bash"