blob: 49e5555fdf84505b8651dc5f19277600b9baf2a3 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Python interface to PROJ (cartographic projections and coordinate transformations library)"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=dc4bb2668871655e24030dfe8d2a7ce7"
4DEPENDS = "python3-cython proj"
5DEPENDS:append:class-target = " python3-cython-native proj-native"
6
7PYPI_PACKAGE = "pyproj"
8
9inherit pypi setuptools3
10
11SRC_URI[sha256sum] = "261eb29b1d55b1eb7f336127344d9b31284d950a9446d1e0d1c2411f7dd8e3ac"
12
13RDEPENDS:${PN} = "${PYTHON_PN}-certifi proj"
14
15export PROJ_INCDIR = "${STAGING_INCDIR}"
16export PROJ_LIBDIR = "${STAGING_LIBDIR}"
17export PROJ_DIR = "${STAGING_BINDIR_NATIVE}/.."