blob: 8b50aabb75dec54a9b911c62ac8c8c72edec2be8 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Python wrapper around rapidjson"
2HOMEPAGE = "https://github.com/python-rapidjson/python-rapidjson"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4daf3929156304df67003c33274a98bd"
6
7SRC_URI = "git://github.com/python-rapidjson/python-rapidjson.git;protocol=https;branch=master"
8SRCREV = "8f4ab8e197ca30c03726b675ae7cce6ac9d6622e"
9
10S = "${WORKDIR}/git"
11
12inherit setuptools3
13
14SETUPTOOLS_BUILD_ARGS += " --rj-include-dir=${RECIPE_SYSROOT}${includedir}"
15
16DEPENDS += " \
17 rapidjson \
18"
19
20RDEPENDS:${PN} += " \
21 ${PYTHON_PN}-core \
22"