blob: 53f8011b02ab2a84e0f5f733a0810e1edc352ae4 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Supervisor: A Process Control System"
2DESCRIPTION = "\
3Supervisor is a client/server system that allows its users \
4to monitorand control a number of processes on UNIX-like \
5operating systems."
6HOMEPAGE = "https://github.com/Supervisor/supervisor"
7LICENSE = "BSD-4-Clause"
8LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=5b4e3a2172bba4c47cded5885e7e507e"
9
10SRC_URI[sha256sum] = "34761bae1a23c58192281a5115fb07fbf22c9b0133c08166beffc70fed3ebc12"
11
12PYPI_PACKAGE = "supervisor"
13inherit pypi systemd setuptools3
14RDEPENDS:${PN} = "\
15 python3-meld3 \
16 python3-io \
17 python3-xmlrpc \
18 python3-resource \
19 python3-setuptools \
20 python3-smtpd \
21"
22
23SRC_URI += "file://supervisord.conf \
24 file://supervisor.service \
25 "
26SYSTEMD_SERVICE:${PN} = "supervisor.service"
27
28do_install:append() {
29 install -d ${D}${sysconfdir}/supervisor
30 install -d ${D}${systemd_system_unitdir}
31
32 install -m 0644 ${WORKDIR}/supervisord.conf ${D}${sysconfdir}/supervisor
33 install -m 0644 ${WORKDIR}/supervisor.service ${D}${systemd_system_unitdir}
34}