blob: ee12deffb513bb5864c413b3f06cf9931f55a4d9 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Ultra fast JSON encoder and decoder for Python"
2DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
3
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e0039a83d8a99726b5418f0b03302d0a"
6
7SRC_URI[sha256sum] = "f881e2d8a022e9285aa2eab6ba8674358dbcb2b57fa68618d88d62937ac3ff04"
8
9inherit pypi ptest setuptools3
10
11SRC_URI += " \
12 file://run-ptest \
13 file://0001-setup.py-Do-not-strip-debugging-symbols.patch \
14"
15
16DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
17
18RDEPENDS:${PN} += "\
19 ${PYTHON_PN}-datetime \
20 ${PYTHON_PN}-numbers \
21"
22
23RDEPENDS:${PN}-ptest += " \
24 ${PYTHON_PN}-json \
25 ${PYTHON_PN}-pytest \
26 ${PYTHON_PN}-pytz \
27"
28
29do_install_ptest() {
30 install -d ${D}${PTEST_PATH}/tests
31 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
32}
33
34BBCLASSEXTEND = "native nativesdk"