blob: c4d74306ce9601776cb04c671174fafd6e345d78 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "xxhash is a Python binding for the xxHash library by Yann Collet."
2SECTION = "devel/python"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3a9dab7f159514231249aa3e108ab26b"
5
6SRC_URI[sha256sum] = "1afd47af8955c5db730f630ad53ae798cf7fae0acb64cebb3cf94d35c47dd088"
7
8SRC_URI += " \
9 file://run-ptest \
10"
11
12inherit pypi setuptools3 ptest
13
14RDEPENDS:${PN}-ptest += " \
15 ${PYTHON_PN}-pytest \
16"
17
18do_install_ptest() {
19 install -d ${D}${PTEST_PATH}/tests
20 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
21}