blob: 71e74e86f2d8faa9557c39dd87bbc55ece3a5c3b [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Yet Another Python Profiler"
2HOMEPAGE = "https://github.com/sumerc/yappi"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=71c208c9a4fd864385eb69ad4caa3bee"
6
7SRC_URI[sha256sum] = "504b5d8fc7433736cb5e257991d2e7f2946019174f1faec7b2fe947881a17fc0"
8
9SRC_URI += " \
10 file://run-ptest \
11 file://0001-Fix-imports-for-ptests.patch \
12 file://0002-add-3.11-to-the-setup.patch \
13"
14
15inherit pypi setuptools3 ptest
16
17RDEPENDS:${PN} += "\
18 ${PYTHON_PN}-datetime \
19 ${PYTHON_PN}-pickle \
20 ${PYTHON_PN}-threading \
21"
22
23RDEPENDS:${PN}-ptest += " \
24 ${PYTHON_PN}-gevent \
25 ${PYTHON_PN}-multiprocessing \
26 ${PYTHON_PN}-pytest \
27 ${PYTHON_PN}-profile \
28 ${PYTHON_PN}-zopeinterface \
29"
30
31do_install_ptest() {
32 install -d ${D}${PTEST_PATH}/tests
33 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
34 cp -f ${S}/yappi/yappi.py ${D}/${PTEST_PATH}/
35}
36