blob: bf87b0a73d14836cf168868b90d3debad24f9848 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Python3 interface to the wxWidgets Cross-platform C++ GUI toolkit."
2HOMEPAGE = "http://www.wxpython.org"
3
4LICENSE = "LGPL-2.0-only & WXwindows"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=bdabf9e11191e2b9d3b6aef5f338ec00"
6
7DEPENDS = "python3-attrdict3-native python3-six-native wxwidgets-native \
8 wxwidgets \
9 "
10
11PYPI_PACKAGE = "wxPython"
12
13SRC_URI += "file://add-back-option-build-base.patch \
14 file://wxgtk-fixup-build-scripts.patch \
15 file://not-overwrite-cflags-cxxflags.patch \
16 file://0001-pypubsub-Replace-deprecated-inspect.getargspec.patch \
17 file://0001-sip-Conditionally-use-GetAssertStackTrace-under-USE_.patch \
18 "
19SRC_URI[sha256sum] = "663cebc4509d7e5d113518865fe274f77f95434c5d57bc386ed58d65ceed86c7"
20
21S = "${WORKDIR}/wxPython-${PV}"
22
23inherit pypi setuptools3 pkgconfig features_check
24
25REQUIRED_DISTRO_FEATURES = "x11"
26
27export WX_CONFIG = "'${RECIPE_SYSROOT_NATIVE}${bindir}/wx-config --prefix=${STAGING_EXECPREFIXDIR} --baselib=${baselib}'"
28
29RDEPENDS:${PN} = "\
30 python3-difflib \
31 python3-image \
32 python3-numpy \
33 python3-pillow \
34 python3-pip \
35 python3-pprint \
36 python3-pycairo \
37 python3-six \
38 python3-xml \
39"