blob: a493412403381bec1d7a5c3a0229131a0868a1a5 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "cui/gui tool for tuning of running processes"
2HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Tuna"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
5
6SRC_URI = "git://git.kernel.org/pub/scm/utils/tuna/tuna.git;branch=main"
7
8SRCREV = "0681906e75e1c8166126bbfc2f3055e7507bfcb5"
9
10S = "${WORKDIR}/git"
11
12RDEPENDS:${PN} += " \
13 python3-io \
14 python3-linux-procfs \
15 python3-logging \
16 python3-six \
17 "
18
19inherit setuptools3
20
21do_install:append() {
22 install -m 0755 -d ${D}${bindir}
23 install -m 0755 ${S}/tuna-cmd.py ${D}${bindir}/tuna
24}