blob: 69996d2a3f62b6b6843a10fbde65391ce8dd6d6c [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Sensors plugin for the Xfce Panel"
2HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
3LICENSE = "GPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6inherit xfce-panel-plugin
7
8SRC_URI += "file://0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch"
9SRC_URI[sha256sum] = "6c1605a738e5df40e084d08ac93f962cd445093396de1e9bfadc7ab4588c36b6"
10
11EXTRA_OECONF = " \
12 --disable-procacpi \
13 --disable-xnvctrl \
14"
15
16do_configure:prepend() {
17 sed -i 's:LIBSENSORS_CFLAGS=.*:LIBSENSORS_CFLAGS=-I${STAGING_INCDIR}:g' ${S}/configure.ac
18}
19
20PACKAGECONFIG ??= "libnotify"
21PACKAGECONFIG[libsensors] = "--enable-libsensors,--disable-libsensors, lmsensors"
22PACKAGECONFIG[hddtemp] = "--enable-hddtemp,--disable-hddtemp, hddtemp"
23PACKAGECONFIG[netcat] = "--enable-netcat,--disable-netcat, netcat"
24PACKAGECONFIG[libnotify] = "--enable-notification,--disable-notification, libnotify"
25
26FILES_SOLIBSDEV = "${libdir}/xfce4/modules/lib*${SOLIBSDEV}"