blob: 6a1ee7b7fdaeb1d63162ab8ef77eb6e8e44f19a2 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Xfce Menu Library"
2SECTION = "x11/libs"
3LICENSE = "LGPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=04a01abcbdabffae1ca26335a293276b"
5DEPENDS = "xfce4-dev-tools-native libxfce4ui intltool-native"
6
7inherit xfce gtk-doc gobject-introspection features_check
8
9# xfce4 depends on libwnck3, gtk+3 and libepoxy need to be built with x11 PACKAGECONFIG.
10# cairo would at least needed to be built with xlib.
11ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
12
13SRC_URI += "file://0001-xfce-applications.menu-don-t-bloat-settings-menu-by-.patch"
14SRC_URI[sha256sum] = "54633487566a8b8502b71c11a7f719efe27c069bd5773cc95f11ff4ea8f11a14"
15
16EXTRA_OECONF = "--disable-gtk-doc"
17
18do_compile:prepend() {
19 export GIR_EXTRA_LIBS_PATH="${B}/garcon/.libs"
20}
21
22FILES:${PN} += "${datadir}/desktop-directories"