blob: 0472d4885f67060b4e88a5359f57258262e14af6 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Thumbnail service implementing the thumbnail management D-Bus specification"
2SECTION = "x11/libs"
3LICENSE = "GPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5DEPENDS = "freetype gdk-pixbuf poppler curl xfce4-dev-tools-native libxml2 libgsf libxfce4util"
6
7inherit xfce gtk-doc systemd
8
9SRC_URI[sha256sum] = "4087f3af4ef31271d3f315421a2f1fe67e4fda7ad60bbab1f073627914dfcf00"
10
11INSANE_SKIP:${PN} = "dev-so"
12
13PACKAGECONFIG ??= ""
14PACKAGECONFIG[gstreamer-thumbnailer] = "--enable-gstreamer-thumbnailer,--disable-gstreamer-thumbnailer,gstreamer1.0 gstreamer1.0-plugins-base"
15
16do_install:append() {
17 # Makefile seems to race on creation of symlink. So ensure creation here
18 # until fixed properly
19 ln -sf tumbler-xdg-cache.so ${D}${libdir}/tumbler-1/plugins/cache/tumbler-cache-plugin.so
20}
21
22FILES:${PN} += "${datadir}/dbus-1/services \
23 ${libdir}/tumbler-1/tumblerd \
24 ${libdir}/tumbler-1/plugins/*.so \
25 ${libdir}/tumbler-1/plugins/cache/*.so \
26 ${systemd_user_unitdir}/tumblerd.service \
27"
28
29FILES:${PN}-dev += "${libdir}/tumbler-1/plugins/*.la \
30 ${libdir}/tumbler-1/plugins/cache/*.la \
31"