blob: f61c9cd6a51765c1f7e057c708df7ba5df637b32 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Power manager for the Xfce desktop environment"
2HOMEPAGE = "http://goodies.xfce.org/projects/applications/xfce4-power-manager"
3SECTION = "x11"
4
5LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
7
8inherit xfce features_check
9
10REQUIRED_DISTRO_FEATURES = "x11"
11
12DEPENDS += "libnotify libxrandr virtual/libx11 libxext xfce4-panel upower libxscrnsaver"
13
14SRC_URI[sha256sum] = "2eee467886252f9fa704c978ec67dafad5274ede93e59b092a688faa7e72c39a"
15
16EXTRA_OECONF = " \
17 --enable-network-manager \
18 --enable-panel-plugins \
19"
20
21PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)}"
22PACKAGECONFIG[polkit] = "--enable-polkit, --disable-polkit, polkit"
23
24PACKAGES += "xfce4-powermanager-plugin"
25
26FILES:${PN} += " \
27 ${datadir}/polkit-1 \
28 ${datadir}/metainfo \
29"
30
31FILES:xfce4-powermanager-plugin = " \
32 ${libdir}/xfce4 \
33 ${datadir}/xfce4 \
34"
35
36RDEPENDS:xfce4-powermanager-plugin = "${PN}"
37RDEPENDS:${PN} = "networkmanager ${@bb.utils.contains('DISTRO_FEATURES','systemd','','consolekit',d)}"
38
39# xfce4-brightness-plugin was replaced by xfce4-powermanager-plugin
40RPROVIDES:xfce4-powermanager-plugin += "xfce4-brightness-plugin"
41RREPLACES:xfce4-powermanager-plugin += "xfce4-brightness-plugin"
42RCONFLICTS:xfce4-powermanager-plugin += "xfce4-brightness-plugin"