blob: 53d5abb07e4a15397d8b3e7e5d09abb7bf8905b9 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Tools for TPM2."
2DESCRIPTION = "tpm2-tools"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://docs/LICENSE;md5=a846608d090aa64494c45fc147cc12e3"
5SECTION = "tpm"
6
7DEPENDS = "tpm2-abrmd tpm2-tss openssl curl autoconf-archive"
8
9SRC_URI = "https://github.com/tpm2-software/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.gz"
10
11SRC_URI[sha256sum] = "e7ce2fd36ef5cdbd7872d823a442e8754a4f0ca7c54b60efcdb75c12a1f98f8f"
12
13UPSTREAM_CHECK_URI = "https://github.com/tpm2-software/${BPN}/releases"
14
15inherit autotools pkgconfig bash-completion
16
17do_configure:prepend() {
18 # do not extract the version number from git
19 sed -i -e 's/m4_esyscmd_s(\[git describe --tags --always --dirty\])/${PV}/' ${S}/configure.ac
20}
21
22# need tss-esys
23RDEPENDS:${PN} = "libtss2 tpm2-abrmd"