blob: 0419d07c4eb226d4c1acc68357db596d1684ce9a [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "a fast C/C++ compiler cache"
2DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
3by caching the result of previous compilations and detecting when the \
4same compilation is being done again. Supported languages are C, C\+\+, \
5Objective-C and Objective-C++."
6HOMEPAGE = "http://ccache.samba.org"
7SECTION = "devel"
8
9LICENSE = "GPL-3.0-or-later"
10LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=8fc2cae2bbabeb9236cacfa1c83a3dc5"
11
12DEPENDS = "zstd"
13
14SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${BP}.tar.gz \
15 file://0001-xxhash.h-Fix-build-with-gcc-12.patch \
16 "
17SRC_URI[sha256sum] = "dc283906b73bd7c461178ca472a459e9d86b5523405035921bd8204e77620264"
18
19inherit cmake github-releases
20
21PATCHTOOL = "patch"
22
23BBCLASSEXTEND = "native nativesdk"
24
25PACKAGECONFIG[docs] = "-DENABLE_DOCUMENTATION=ON,-DENABLE_DOCUMENTATION=OFF,asciidoc"
26PACKAGECONFIG[redis] = "-DREDIS_STORAGE_BACKEND=ON,-DREDIS_STORAGE_BACKEND=OFF,hiredis"