blob: ddf25b2c9bab6673461ed3dca228d6a762f70f63 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001# This recipe builds a native Go (written in Go) by first building an old Go 1.4
2# (written in C). However this old Go does not support all hosts platforms.
3
4require go-${PV}.inc
5
6inherit native
7
Andrew Geissler87f5cff2022-09-30 13:13:31 -05008SRC_URI += "https://dl.google.com/go/go1.4-bootstrap-20171003.tar.gz;name=bootstrap;subdir=go1.4"
Andrew Geissler9aee5002022-03-30 16:27:02 +00009SRC_URI[bootstrap.sha256sum] = "f4ff5b5eb3a3cae1c993723f3eab519c5bae18866b5e5f96fe1102f0cb5c3e52"
10
11export GOOS = "${BUILD_GOOS}"
12export GOARCH = "${BUILD_GOARCH}"
13CC = "${@d.getVar('BUILD_CC').strip()}"
14
15GOMAKEARGS ?= "--no-banner"
16
17do_configure() {
18 cd ${WORKDIR}/go1.4/go/src
19 CGO_ENABLED=0 GOROOT=${WORKDIR}/go1.4/go ./make.bash
20}
21
22do_compile() {
23 export GOROOT_FINAL="${libdir_native}/go"
24 export GOROOT_BOOTSTRAP="${WORKDIR}/go1.4/go"
25
26 cd src
27 ./make.bash ${GOMAKEARGS}
28 cd ${B}
29}
30do_compile[cleandirs] += "${GOTMPDIR} ${B}/bin"
31
32make_wrapper() {
33 rm -f ${D}${bindir}/$2$3
34 cat <<END >${D}${bindir}/$2$3
35#!/bin/bash
36here=\`dirname \$0\`
37export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}"
38\$here/../lib/go/bin/$1 "\$@"
39END
40 chmod +x ${D}${bindir}/$2
41}
42
43do_install() {
44 install -d ${D}${libdir}/go
45 cp --preserve=mode,timestamps -R ${B}/pkg ${D}${libdir}/go/
46 install -d ${D}${libdir}/go/src
47 (cd ${S}/src; for d in *; do \
48 [ -d $d ] && cp -a ${S}/src/$d ${D}${libdir}/go/src/; \
49 done)
50 find ${D}${libdir}/go/src -depth -type d -name testdata -exec rm -rf {} \;
51 install -d ${D}${bindir} ${D}${libdir}/go/bin
52 for f in ${B}/bin/*
53 do
54 base=`basename $f`
55 install -m755 $f ${D}${libdir}/go/bin
56 make_wrapper $base $base
57 done
58}