blob: 1c3a7e5136efc1065372dfe11b77d10e926ce49c [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Incredibly simple helpers for testing code with exceptions"
2DESCRIPTION = "Test::Fatal is an alternative to the popular Test::Exception.\
3It does much less, but should allow greater flexibility in testing \
4exception-throwing code with about the same amount of typing."
5HOMEPAGE = "https://github.com/rjbs/Test-Fatal"
6BUGTRACKER = "https://github.com/rjbs/Test-Fatal/issues"
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=b5c851290cab1dda12fcfb0e9ec43639"
11
12SRC_URI = "${CPAN_MIRROR}/authors/id/R/RJ/RJBS/Test-Fatal-${PV}.tar.gz"
13
14SRC_URI[sha256sum] = "37dfffdafb84b762efe96b02fb2aa41f37026c73e6b83590db76229697f3c4a6"
15
16S = "${WORKDIR}/Test-Fatal-${PV}"
17
18inherit cpan ptest-perl
19
20RDEPENDS:${PN} += "\
21 libtry-tiny-perl \
22 perl-module-carp \
23 perl-module-exporter \
24 perl-module-test-builder \
25"
26
27RDEPENDS:${PN}-ptest += "\
28 perl-module-extutils-makemaker \
29 perl-module-extutils-mm-unix \
30 perl-module-file-spec \
31 perl-module-overload \
32 perl-module-test-builder-tester \
33 perl-module-test-more \
34"
35
36BBCLASSEXTEND = "native nativesdk"