blob: a3728d84356481b38d0467d5db6602c0ebab95b5 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Try::Tiny - Minimal try/catch with proper preservation of $@"
2DESCRIPTION = "This module provides bare bones try/catch/finally statements \
3that are designed to minimize common mistakes with eval blocks, and NOTHING \
4else."
5HOMEPAGE = "https://github.com/p5sagit/Try-Tiny"
6BUGTRACKER = "https://rt.cpan.org/Public/Dist/Display.html?Name=Try-Tiny"
7SECTION = "libs"
8LICENSE = "MIT"
9
10LIC_FILES_CHKSUM = "file://LICENCE;md5=5dc332c2d4aade55f5db244681000091"
11
12SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETHER/Try-Tiny-${PV}.tar.gz"
13
14SRC_URI[sha256sum] = "3300d31d8a4075b26d8f46ce864a1d913e0e8467ceeba6655d5d2b2e206c11be"
15
16S = "${WORKDIR}/Try-Tiny-${PV}"
17
18inherit cpan ptest-perl
19
20RDEPENDS:${PN} += "\
21 perl-module-carp \
22 perl-module-constant \
23 perl-module-exporter \
24"
25RRECOMMENDS:${PN} += "\
26 perl-module-sub-util \
27"
28RDEPENDS:${PN}-ptest += "\
29 perl-module-extutils-makemaker \
30 perl-module-extutils-mm-unix \
31 perl-module-file-spec \
32 perl-module-if \
33 perl-module-test-more \
34"
35
36BBCLASSEXTEND = "native nativesdk"