blob: 5e15004dd0ffebd14b19a7acf1dcb819467b59d5 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Perl module to manipulate and access URI strings"
2DESCRIPTION = "This package contains the URI.pm module with friends. \
3The module implements the URI class. URI objects can be used to access \
4and manipulate the various components that make up these strings."
5HOMEPAGE = "https://metacpan.org/dist/URI"
6SECTION = "libs"
7LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=d8ca5f628bf2cd180bc4fa044cb8ef41"
10
11SRC_URI = "${CPAN_MIRROR}/authors/id/O/OA/OALDERS/URI-${PV}.tar.gz \
12 file://0001-Skip-TODO-test-cases-that-fail.patch \
13 "
14
15SRC_URI[sha256sum] = "5f7e42b769cb27499113cfae4b786c37d49e7c7d32dbb469602cd808308568f8"
16
17S = "${WORKDIR}/URI-${PV}"
18
19EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
20
21inherit cpan ptest-perl
22
23do_compile() {
24 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
25 cpan_do_compile
26}
27
28do_install:prepend() {
29 # these tests require "-T" (taint) command line option
30 rm -rf ${B}/t/cwd.t
31 rm -rf ${B}/t/file.t
32}
33
34RDEPENDS:${PN} += "\
35 perl-module-integer \
36 perl-module-mime-base64 \
37"
38
39RDEPENDS:${PN}-ptest += " \
40 libtest-fatal-perl \
41 libtest-needs-perl \
42 libtest-warnings-perl \
43 perl-module-encode \
44 perl-module-encode-encoding \
45 perl-module-extutils-makemaker \
46 perl-module-extutils-mm-unix \
47 perl-module-file-spec-functions \
48 perl-module-net-domain \
49 perl-module-perlio \
50 perl-module-perlio-encoding \
51 perl-module-test \
52 perl-module-test-more \
53 perl-module-utf8 \
54"
55
56BBCLASSEXTEND = "native"