blob: 1290fcd2f1c4c215b3f4c83b2c5694b83a16863b [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "With this program/Python library you can easily create mock objects on D-Bus"
2HOMEPAGE = "https://pypi.org/project/python-dbusmock/"
3
4LICENSE = "GPL-3.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
6
7SRC_URI[sha256sum] = "3b496fab84aff3936054f747e9a22bb07ac5783b1d967c6cc39536c7ba315fce"
8
9PYPI_PACKAGE = "python-dbusmock"
10
11inherit pypi python_setuptools_build_meta
12DEPENDS += "python3-setuptools-scm-native"
13
14RDEPENDS:${PN} += "\
15 ${PYTHON_PN}-dbus \
16 ${PYTHON_PN}-pygobject \
17 ${PYTHON_PN}-unittest \
18 ${PYTHON_PN}-xml \
19 "
20
21BBCLASSEXTEND = "native"