blob: 9d860111c14f7ba8f491f1570068ccbee6ac4f54 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Tooling for devicetree validation using YAML and jsonschema"
2HOMEPAGE = "https://github.com/devicetree-org/dt-schema"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=457495c8fa03540db4a576bf7869e811"
5
6inherit pypi setuptools3
7
8PYPI_PACKAGE = "dtschema"
9
10SRC_URI[sha256sum] = "f532d433a915e507d4b426b7ef57a6730d23c0938b682fb4866f9dfa80a58ec6"
11
12DEPENDS += "python3-setuptools-scm-native"
13RDEPENDS:${PN} += "python3-ruamel-yaml python3-jsonschema python3-rfc3987"
14
15BBCLASSEXTEND = "native nativesdk"