blob: e728e47cecb59adca304cd0efe80731960b54e0b [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Library and tool for installing Python wheels"
2DESCRIPTION = "A low-level library for installing a Python package from a wheel distribution."
3HOMEPAGE = "https://installer.readthedocs.io/"
4BUGTRACKER = "https://github.com/pypa/installer/issues"
5
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=5038641aec7a77451e31da828ebfae00"
8
9SRC_URI += "file://interpreter.patch"
10
11SRC_URI[sha256sum] = "f3bd36cd261b440a88a1190b1becca0578fee90b4b62decc796932fdd5ae8839"
12
13inherit pypi python_flit_core
14
15# Bootstrap the native build
16DEPENDS:remove:class-native = "python3-picobuild-native python3-installer-native"
17
18INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode"
19
20do_compile:class-native () {
21 python_flit_core_do_manual_build
22}
23
24do_install:prepend:class-native() {
25 export PYTHONPATH="${S}/src"
26}
27
28BBCLASSEXTEND = "native nativesdk"