blob: 8a950220125e7de128e52dcfcb9933d07b4809ba [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Poetry PEP 517 Build Backend"
2DESCRIPTION = "Poetry PEP 517 Build Backend"
3HOMEPAGE = "https://github.com/python-poetry/poetry-core"
4BUGTRACKER = "https://github.com/python-poetry/poetry-core"
5CHANGELOG = "https://github.com/python-poetry/poetry-core/blob/master/CHANGELOG.md"
6
7LICENSE = "Apache-2.0 & BSD-2-Clause & MIT"
8LIC_FILES_CHKSUM = "\
9 file://LICENSE;md5=78c39cfd009863ae44237a7ab1f9cedc \
10 file://src/poetry/core/_vendor/attr/_version_info.py;beginline=1;endline=1;md5=b2dccaa94b3629a08bfb4f983cad6f89 \
11 file://src/poetry/core/_vendor/attrs/LICENSE;md5=5e55731824cf9205cfabeab9a0600887 \
12 file://src/poetry/core/_vendor/jsonschema/COPYING;md5=7a60a81c146ec25599a3e1dabb8610a8 \
13 file://src/poetry/core/_vendor/lark/LICENSE;md5=fcfbf1e2ecc0f37acbb5871aa0267500 \
14 file://src/poetry/core/_vendor/packaging/LICENSE;md5=faadaedca9251a90b205c9167578ce91 \
15 file://src/poetry/core/_vendor/packaging/LICENSE.APACHE;md5=2ee41112a44fe7014dce33e26468ba93 \
16 file://src/poetry/core/_vendor/packaging/LICENSE.BSD;md5=7bef9bf4a8e4263634d0597e7ba100b8 \
17 file://src/poetry/core/_vendor/pyparsing/LICENSE;md5=657a566233888513e1f07ba13e2f47f1 \
18 file://src/poetry/core/_vendor/pyrsistent/LICENSE.mit;md5=b695eb9c6e7a6fb1b1bc2d193c42776e \
19 file://src/poetry/core/_vendor/tomlkit/LICENSE;md5=31aac0dbc1babd278d5386dadb7f8e82 \
20 file://src/poetry/core/_vendor/typing_extensions.LICENSE;md5=f16b323917992e0f8a6f0071bc9913e2 \
21"
22
23SRC_URI[sha256sum] = "514bd33c30e0bf56b0ed44ee15e120d7e47b61ad908b2b1011da68c48a84ada9"
24
25inherit python_poetry_core pypi
26PYPI_ARCHIVE_NAME = "poetry_core-${PV}.${PYPI_PACKAGE_EXT}"
27S = "${WORKDIR}/poetry_core-${PV}"
28
29SRC_URI += "file://deterministic.patch"
30
31RDEPENDS:${PN}:append:class-target = "\
32 python3-compression \
33 python3-core \
34 python3-crypt \
35 python3-io \
36 python3-json \
37 python3-logging \
38 python3-netclient \
39 python3-pathlib2 \
40 python3-pprint \
41 python3-shell \
42"
43
44RDEPENDS:${PN} += "\
45 python3-pip \
46 python3-six \
47"
48
49BBCLASSEXTEND = "native nativesdk"