blob: a6a69c8b59657a1bc7dc02e4a7d99701b5d6c1a2 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "World timezone definitions, modern and historical"
2HOMEPAGE = "http://pythonhosted.org/pytz"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1a67fc46c1b596cce5d21209bbe75999"
5
6inherit pypi setuptools3 ptest
7
8SRC_URI[sha256sum] = "7ccfae7b4b2c067464a6733c6261673fdb8fd1be905460396b97a073e9fa683a"
9
10RDEPENDS:${PN}:class-target += "\
11 ${PYTHON_PN}-datetime \
12 ${PYTHON_PN}-doctest \
13 ${PYTHON_PN}-io \
14 ${PYTHON_PN}-pickle \
15 ${PYTHON_PN}-pprint \
16 ${PYTHON_PN}-threading \
17"
18
19BBCLASSEXTEND = "native nativesdk"
20
21SRC_URI += " \
22 file://run-ptest \
23"
24
25RDEPENDS:${PN}-ptest += " \
26 ${PYTHON_PN}-pytest \
27"
28
29do_install_ptest() {
30 install -d ${D}${PTEST_PATH}/pytz
31 install -d ${D}${PTEST_PATH}/pytz/tests
32 cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/
33 cp -f ${S}/README.rst ${D}${PTEST_PATH}/
34
35}