blob: 5e565e745d6cc172d764eac11a1b518851388029 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Python documentation generator"
2HOMEPAGE = "http://sphinx-doc.org/"
3SECTION = "devel/python"
4LICENSE = "BSD-2-Clause & MIT & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2214a89317448c7f792f5b75dd6726e4"
6
7PYPI_PACKAGE = "Sphinx"
8
9SRC_URI[sha256sum] = "58c140ecd9aa0abbc8ff6da48a266648eac9e5bfc8e49576efd2979bf46f5961"
10
11inherit python_flit_core pypi
12
13
14do_install:append () {
15 # The cache format of "{None, 'en', 'ja'}" doesn't seem to be consistent (dict ordering?)
16 rm ${D}${libdir}/${PYTHON_DIR}/site-packages/sphinx/writers/__pycache__/*latex*
17}
18
19RDEPENDS:${PN} = "\
20 python3-alabaster \
21 python3-babel \
22 python3-docutils \
23 python3-imagesize \
24 python3-jinja2 \
25 python3-packaging \
26 python3-pygments \
27 python3-requests \
28 python3-snowballstemmer \
29 python3-sphinxcontrib-applehelp \
30 python3-sphinxcontrib-devhelp \
31 python3-sphinxcontrib-htmlhelp \
32 python3-sphinxcontrib-jsmath \
33 python3-sphinxcontrib-qthelp \
34 python3-sphinxcontrib-serializinghtml \
35 "
36
37BBCLASSEXTEND = "native nativesdk"