blob: 7af95117cf1ffd9bbfd6547e3ff651cb03d96c21 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Python HTTP library with thread-safe connection pooling, file post support, sanity friendly, and more"
2HOMEPAGE = "https://github.com/shazow/urllib3"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c2823cb995439c984fd62a973d79815c"
5
6SRC_URI[sha256sum] = "c083dd0dce68dbfbe1129d5271cb90f9447dea7d52097c6e0126120c521ddea8"
7
8inherit pypi setuptools3
9
10RDEPENDS:${PN} += "\
11 ${PYTHON_PN}-certifi \
12 ${PYTHON_PN}-cryptography \
13 ${PYTHON_PN}-email \
14 ${PYTHON_PN}-idna \
15 ${PYTHON_PN}-netclient \
16 ${PYTHON_PN}-pyopenssl \
17 ${PYTHON_PN}-threading \
18 ${PYTHON_PN}-logging \
19"
20
21CVE_PRODUCT = "urllib3"
22
23BBCLASSEXTEND = "native nativesdk"