blob: 70ebafc1689d94e884b2c00c1c3c61432fdb611c [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Backport of pathlib-compatible object wrapper for zip files"
2HOMEPAGE = "https://github.com/jaraco/zipp"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
5
6SRC_URI[sha256sum] = "a7a22e05929290a67401440b39690ae6563279bced5f314609d9d03798f56766"
7
8DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
9
10inherit pypi python_setuptools_build_meta
11
12DEPENDS += "${PYTHON_PN}-toml-native"
13
14RDEPENDS:${PN} += "${PYTHON_PN}-compression \
15 ${PYTHON_PN}-math \
16 ${PYTHON_PN}-more-itertools"
17
18BBCLASSEXTEND = "native nativesdk"