blob: 1981a7524c1fe3af0ed838cc019b6fba35f9f14d [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "An interpreter of object-oriented scripting language"
2DESCRIPTION = "Ruby is an interpreted scripting language for quick \
3and easy object-oriented programming. It has many features to process \
4text files and to do system management tasks (as in Perl). \
5It is simple, straight-forward, and extensible. \
6"
7HOMEPAGE = "http://www.ruby-lang.org/"
8SECTION = "devel/ruby"
9LICENSE = "Ruby | BSD-2-Clause | BSD-3-Clause | GPL-2.0-only | ISC | MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=5b8c87559868796979806100db3f3805 \
11 file://BSDL;md5=8b50bc6de8f586dc66790ba11d064d75 \
12 file://GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
13 file://LEGAL;md5=f260190bc1e92e363f0ee3c0463d4c7c \
14 "
15
16DEPENDS = "zlib openssl libyaml gdbm readline libffi"
17DEPENDS:append:class-target = " ruby-native"
18DEPENDS:append:class-nativesdk = " ruby-native"
19
20SHRT_VER = "${@oe.utils.trim_version("${PV}", 2)}"
21SRC_URI = "http://cache.ruby-lang.org/pub/ruby/${SHRT_VER}/ruby-${PV}.tar.gz \
22 file://0001-extmk-fix-cross-compilation-of-external-gems.patch \
23 file://0002-Obey-LDFLAGS-for-the-link-of-libruby.patch \
24 file://remove_has_include_macros.patch \
25 file://run-ptest \
26 file://0001-template-Makefile.in-do-not-write-host-cross-cc-item.patch \
27 file://0002-template-Makefile.in-filter-out-f-prefix-map.patch \
28 file://0003-rdoc-build-reproducible-documentation.patch \
29 file://0004-lib-mkmf.rb-sort-list-of-object-files-in-generated-M.patch \
30 file://0005-Mark-Gemspec-reproducible-change-fixing-784225-too.patch \
31 file://0006-Make-gemspecs-reproducible.patch \
32 file://0001-vm_dump.c-Define-REG_S1-and-REG_S2-for-musl-riscv.patch \
33 "
34UPSTREAM_CHECK_URI = "https://www.ruby-lang.org/en/downloads/"
35
36inherit autotools ptest pkgconfig
37
38
39# This snippet lets compiled extensions which rely on external libraries,
40# such as zlib, compile properly. If we don't do this, then when extmk.rb
41# runs, it uses the native libraries instead of the target libraries, and so
42# none of the linking operations succeed -- which makes extconf.rb think
43# that the libraries aren't available and hence that the extension can't be
44# built.
45
46do_configure:prepend() {
47 sed -i "s#%%TARGET_CFLAGS%%#$CFLAGS#; s#%%TARGET_LDFLAGS%%#$LDFLAGS#" ${S}/common.mk
48 rm -rf ${S}/ruby/
49}
50
51DEPENDS:append:libc-musl = " libucontext"
52
53SRC_URI[sha256sum] = "daaa78e1360b2783f98deeceb677ad900f3a36c0ffa6e2b6b19090be77abc272"
54
55PACKAGECONFIG ??= ""
56PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
57
58PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind"
59PACKAGECONFIG[gmp] = "--with-gmp=yes, --with-gmp=no, gmp"
60PACKAGECONFIG[ipv6] = "--enable-ipv6, --disable-ipv6,"
61# rdoc is off by default due to non-reproducibility reported in
62# https://bugs.ruby-lang.org/issues/18456
63PACKAGECONFIG[rdoc] = "--enable-install-rdoc,--disable-install-rdoc,"
64
65EXTRA_OECONF = "\
66 --disable-versioned-paths \
67 --disable-rpath \
68 --disable-dtrace \
69 --enable-shared \
70 --enable-load-relative \
71 --with-pkg-config=pkg-config \
72 --with-static-linked-ext \
73"
74
75EXTRA_OECONF:append:libc-musl = "\
76 ac_cv_func_isnan=yes \
77 ac_cv_func_isinf=yes \
78"
79
80PARALLEL_MAKEINST = ""
81
82do_install:append:class-target () {
83 # Find out rbconfig.rb from .installed.list
84 rbconfig_rb=`grep rbconfig.rb ${B}/.installed.list`
85 # Remove build host directories
86 sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' \
87 -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
88 -e 's|${DEBUG_PREFIX_MAP}||g' \
89 -e 's:${HOSTTOOLS_DIR}/::g' \
90 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
91 -e 's:${RECIPE_SYSROOT}::g' \
92 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
93 ${D}$rbconfig_rb
94
95 sed -i -e 's|${DEBUG_PREFIX_MAP}||g' \
96 ${D}${libdir}/pkgconfig/*.pc
97
98 # logs that may contain host-specific paths
99 find ${D} -name gem_make.out -delete
100}
101
102do_install_ptest () {
103 cp -rf ${S}/test ${D}${PTEST_PATH}/
104
105 install -D ${S}/tool/test/runner.rb ${D}${PTEST_PATH}/tool/test/runner.rb
106 cp -r ${S}/tool/lib ${D}${PTEST_PATH}/tool/
107 mkdir -p ${D}${PTEST_PATH}/lib
108 cp -r ${S}/lib/did_you_mean ${S}/lib/rdoc ${D}${PTEST_PATH}/lib
109
110 # install test-binaries
111 # These .so files have sporadic reproducibility fails as seen here:
112 # https://autobuilder.yocto.io/pub/repro-fail/oe-reproducible-20220107-rm1diuww/packages/diff-html/
113 # As they are needed only in ruby-ptest, and that is currently altogether disabled, let's take them out.
114 # If someone wants to look at where the non-determinism comes from, one possible reason is use of
115 # -rdynamic -Wl,-export-dynamic
116 #find $(find ./.ext -path '*/-test-') -name '*.so' -print0 \
117 # | tar --no-recursion --null -T - --no-same-owner --preserve-permissions -cf - \
118 # | tar -C ${D}${libdir}/ruby/${SHRT_VER}.0/ --no-same-owner --preserve-permissions --strip-components=2 -xf -
119 # adjust path to not assume build directory layout
120 sed -e 's|File.expand_path(.*\.\./bin/erb[^)]*|File.expand_path("${bindir}/erb"|g' \
121 -i ${D}${PTEST_PATH}/test/erb/test_erb_command.rb
122
123 cp -r ${S}/include ${D}/${libdir}/ruby/
124}
125
126PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc"
127
128SUMMARY:${PN}-ri-docs = "ri (Ruby Interactive) documentation for the Ruby standard library"
129RDEPENDS:${PN}-ri-docs = "${PN}"
130FILES:${PN}-ri-docs += "${datadir}/ri"
131
132SUMMARY:${PN}-rdoc = "RDoc documentation generator from Ruby source"
133RDEPENDS:${PN}-rdoc = "${PN}"
134FILES:${PN}-rdoc += "${libdir}/ruby/*/rdoc ${bindir}/rdoc"
135
136FILES:${PN} += "${datadir}/rubygems"
137
138FILES:${PN}-ptest:append:class-target = "\
139 ${libdir}/ruby/include \
140 ${libdir}/ruby/${SHRT_VER}.0/*/-test- \
141"
142
143BBCLASSEXTEND = "native nativesdk"