blob: cd3731cf74f9d2390773470bfe8636ab81ab549b [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A library for text mode user interfaces"
2
3DESCRIPTION = "Newt is a programming library for color text mode, widget based user \
4interfaces. Newt can be used to add stacked windows, entry widgets, \
5checkboxes, radio buttons, labels, plain text fields, scrollbars, \
6etc., to text mode user interfaces. This package also contains the \
7shared library needed by programs built with newt, as well as a \
8/usr/bin/dialog replacement called whiptail. Newt is based on the \
9slang library."
10
11HOMEPAGE = "https://releases.pagure.org/newt/"
12SECTION = "libs"
13
14LICENSE = "LGPL-2.0-only"
15LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
16
17# slang needs to be >= 2.2
18DEPENDS = "slang popt python3"
19
20SRC_URI = "https://releases.pagure.org/newt/newt-${PV}.tar.gz \
21 file://cross_ar.patch \
22 file://Makefile.in-Add-tinfo-library-to-the-linking-librari.patch \
23 file://0001-detect-gold-as-GNU-linker-too.patch \
24 "
25
26SRC_URI[sha256sum] = "caa372907b14ececfe298f0d512a62f41d33b290610244a58aed07bbc5ada12a"
27
28S = "${WORKDIR}/newt-${PV}"
29
30inherit autotools-brokensep python3native python3-dir python3targetconfig
31
32EXTRA_OECONF = "--without-tcl --with-python"
33
34EXTRA_OEMAKE += "PYTHONVERS=${PYTHON_DIR}"
35
36CLEANBROKEN = "1"
37
38export CPPFLAGS
39
40PACKAGES:prepend = "whiptail ${PN}-python "
41
42RDEPENDS:${PN}-python += "python3-core"
43FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*"
44
45do_configure:prepend() {
46 sh autogen.sh
47}
48
49do_compile:prepend() {
50 # Make sure the recompile is OK
51 rm -f ${B}/.depend
52}
53
54FILES:whiptail = "${bindir}/whiptail"
55
56BBCLASSEXTEND = "native nativesdk"