blob: f0f92115948a53d772c6261f4c2666b07ec34996 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Documentation system for on-line information and printed output"
2DESCRIPTION = "Texinfo is a documentation system that can produce both \
3online information and printed output from a single source file. The \
4GNU Project uses the Texinfo file format for most of its documentation."
5HOMEPAGE = "http://www.gnu.org/software/texinfo/"
6SECTION = "console/utils"
7LICENSE = "GPL-3.0-or-later"
8LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
9
10PROVIDES:append:class-native = " texinfo-replacement-native"
11
12def compress_pkg(d):
13 if bb.data.inherits_class('compress_doc', d):
14 compress = d.getVar("DOC_COMPRESS")
15 if compress == "gz":
16 return "gzip"
17 elif compress == "bz2":
18 return "bzip2"
19 elif compress == "xz":
20 return "xz"
21 return ""
22
23RDEPENDS:info += "${@compress_pkg(d)}"
24
25DEPENDS = "zlib ncurses texinfo-replacement-native"
26DEPENDS:class-native = "zlib-native ncurses-native"
27
28TARGET_PATCH = "file://use_host_makedoc.patch"
29TARGET_PATCH:class-native = ""
30
31SRC_URI = "${GNU_MIRROR}/texinfo/${BP}.tar.gz \
32 file://disable-native-tools.patch \
33 file://link-zip.patch \
34 file://dont-depend-on-help2man.patch \
35 ${TARGET_PATCH} \
36 "
37
38SRC_URI[sha256sum] = "53c01dd34c9bf116866d03aabd38c5cd9ee95ac10043d61aa33dec0d27825d8d"
39
40tex_texinfo = "texmf/tex/texinfo"
41
42inherit gettext autotools multilib_script
43
44MULTILIB_SCRIPTS = "${PN}:${bindir}/texi2any"
45
46EXTRA_AUTORECONF += "-I ${S}/gnulib/m4"
47
48do_configure:prepend () {
49 # autotools_do_configure updates po/Makefile.in.in, we also need
50 # update po_document.
51 cp -f ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po_document/
52}
53
54do_compile:prepend() {
55 if [ -d tools ];then
56 oe_runmake -C tools/gnulib/lib
57 fi
58}
59
60do_install:append() {
61 mkdir -p ${D}${datadir}/${tex_texinfo}
62 install -p -m644 ${S}/doc/texinfo.tex ${S}/doc/txi-??.tex ${D}${datadir}/${tex_texinfo}
63 sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/texi2any ${D}${bindir}/pod2texi
64 sed -i -e 's,${HOSTTOOLS_DIR},,' ${D}${bindir}/texindex
65}
66
67do_install:append:class-native() {
68 install -m 755 info/makedoc ${D}${bindir}
69}
70
71PACKAGES += "info info-doc"
72
73FILES:info = "${bindir}/info ${bindir}/infokey ${bindir}/install-info"
74FILES:info-doc = "${infodir}/info.info* ${infodir}/dir ${infodir}/info-*.info* \
75 ${mandir}/man1/info.1* ${mandir}/man5/info.5* \
76 ${mandir}/man1/infokey.1* ${mandir}/man1/install-info.1*"
77
78FILES:${PN} = "${bindir}/makeinfo ${bindir}/texi* ${bindir}/pdftexi2dvi ${bindir}/pod2texi ${datadir}/texinfo"
79RDEPENDS:${PN} = "perl"
80FILES:${PN}-doc = "${infodir}/texi* \
81 ${datadir}/${tex_texinfo} \
82 ${mandir}/man1 ${mandir}/man5"
83
84# Lie about providing the Locale::gettext_xs module. It is not actually built,
85# but the code will test for it and if not found use Locale::gettext_pp instead.
86# However, this causes a file dependency on perl(Locale::gettext_xs) to be
87# generated, which must be satisfied.
88RPROVIDES:${PN} += "perl(Locale::gettext_xs)"
89
90BBCLASSEXTEND = "native nativesdk"