blob: 4a6007b0df3a2bbbcbf4bbeeba08d220bc1c4781 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "WebKit based web browser for GNOME"
2DESCRIPTION = "Epiphany is an open source web browser for the Linux desktop environment. \
3It provides a simple and easy-to-use internet browsing experience."
4HOMEPAGE = "https://wiki.gnome.org/Apps/Web"
5BUGTRACKER = "https://gitlab.gnome.org/GNOME/epiphany"
6LICENSE = "GPL-3.0-or-later"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
9DEPENDS = " \
10 webkitgtk \
11 gcr3 \
12 gsettings-desktop-schemas \
13 nettle \
14 json-glib \
15 libarchive \
16 libdazzle \
17 libhandy \
18 libportal \
19 libsoup \
20 glib-2.0-native \
21 coreutils-native \
22 desktop-file-utils-native \
23 "
24
25GNOMEBASEBUILDCLASS = "meson"
26inherit gnomebase gsettings features_check gettext mime-xdg gtk-icon-cache
27REQUIRED_DISTRO_FEATURES = "x11 opengl"
28
29SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@oe.utils.trim_version("${PV}", 1)}/${GNOMEBN}-${PV}.tar.${GNOME_COMPRESS_TYPE};name=archive \
30 file://0002-help-meson.build-disable-the-use-of-yelp.patch \
31 file://migrator.patch \
32 file://distributor.patch \
33 "
34SRC_URI[archive.sha256sum] = "b66d499f9ee72696d83cf844125377181a954554a4bb3785b73293380ac0c227"
35
36# Developer mode enables debugging
37PACKAGECONFIG[developer-mode] = "-Ddeveloper_mode=true,-Ddeveloper_mode=false"
38
39FILES:${PN} += "${datadir}/dbus-1 ${datadir}/gnome-shell/search-providers ${datadir}/metainfo"
40RDEPENDS:${PN} = "iso-codes adwaita-icon-theme gsettings-desktop-schemas"