blob: ca58ef41386c3af853429952c8360f3cc15f93ed [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "libportal provides GIO-style async APIs for most Flatpak portals."
2DESCRIPTION = "It provides simple asynchronous wrappers for most Flatpak portals \
3with a familiar GObject API along side the D-Bus API"
4HOMEPAGE = "https://github.com/flatpak/libportal"
5BUGTRACKER = "https://github.com/flatpak/libportal/issues"
6LICENSE = "LGPL-3.0-only"
7LIC_FILES_CHKSUM = "file://COPYING;md5=3000208d539ec061b899bce1d9ce9404"
8
9SRC_URI = "git://github.com/flatpak/${BPN}.git;protocol=https;branch=main"
10SRCREV = "13df0b887a7eb7b0f9b14069561a41f62e813155"
11S = "${WORKDIR}/git"
12
13inherit meson gi-docgen gobject-introspection vala features_check pkgconfig
14GIDOCGEN_MESON_OPTION = 'docs'
15
16ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
17
18DEPENDS += "glib-2.0 glib-2.0-native gtk+3 gtk4"
19
20EXTRA_OEMESON = "-Dbackends=gtk3,gtk4"