blob: 6779f39c4f35805f480cbf910e4b9959e4ad9ec2 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPL-2.0-or-later"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14GNOMEBASEBUILDCLASS = "meson"
15
16inherit gnomebase gi-docgen ptest-gnome upstream-version-is-even gobject-introspection
17
18UPSTREAM_CHECK_REGEX = "pango-(?P<pver>\d+\.(?!9\d+)\d+\.\d+)"
19
20GIR_MESON_ENABLE_FLAG = "enabled"
21GIR_MESON_DISABLE_FLAG = "disabled"
22
23SRC_URI += "file://run-ptest \
24 file://0001-Skip-running-test-layout-test.patch \
25 "
26
27SRC_URI[archive.sha256sum] = "caef96d27bbe792a6be92727c73468d832b13da57c8071ef79b9df69ee058fe3"
28
29DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
30
31PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
32 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
33
34PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
35PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false"
36PACKAGECONFIG[thai] = ",,libthai"
37
38GIR_MESON_OPTION = 'introspection'
39
40do_configure:prepend() {
41 chmod +x ${S}/tests/*.py
42}
43
44LEAD_SONAME = "libpango-1.0*"
45
46FILES:${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
47
48RDEPENDS:${PN}-ptest += "cantarell-fonts"
49RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us"
50
51RPROVIDES:${PN} += "pango-modules pango-module-indic-lang \
52 pango-module-basic-fc pango-module-arabic-lang"
53
54BBCLASSEXTEND = "native nativesdk"