blob: c921bdef7213e3fa6336131b729a494944e90188 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The SPIR-V Tools project provides an API and commands for \
2processing SPIR-V modules"
3DESCRIPTION = "The project includes an assembler, binary module parser, \
4disassembler, validator, and optimizer for SPIR-V."
5HOMEPAGE = "https://github.com/KhronosGroup/SPIRV-Tools"
6SECTION = "graphics"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
9
10SRCREV = "40f5bf59c6acb4754a0bffd3c53a715732883a12"
11SRC_URI = "git://github.com/KhronosGroup/SPIRV-Tools.git;branch=master;protocol=https"
12PE = "1"
13UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
14S = "${WORKDIR}/git"
15
16inherit cmake python3native
17
18DEPENDS = "spirv-headers"
19
20EXTRA_OECMAKE += "\
21 -DSPIRV-Headers_SOURCE_DIR=${STAGING_EXECPREFIXDIR} \
22 -DSPIRV_TOOLS_BUILD_STATIC=OFF \
23 -DBUILD_SHARED_LIBS=ON \
24 -DSPIRV_SKIP_TESTS=ON \
25"
26
27do_install:append:class-target() {
28 # Properly set _IMPORT_PREFIX in INTERFACE_LINK_LIBRARIES so that dependent
29 # tools can find the right library
30 sed -i ${D}${libdir}/cmake/SPIRV-Tools/SPIRV-ToolsTarget.cmake \
31 -e 's:INTERFACE_LINK_LIBRARIES.*$:INTERFACE_LINK_LIBRARIES "\$\{_IMPORT_PREFIX\}/lib":'
32}
33
34# all the libraries are unversioned, so don't pack it on PN-dev
35SOLIBS = ".so"
36FILES_SOLIBSDEV = ""
37
38PACKAGES =+ "${PN}-lesspipe"
39FILES:${PN}-lesspipe = "${base_bindir}/spirv-lesspipe.sh"
40RDEPENDS:${PN}-lesspipe += "${PN} bash"
41
42BBCLASSEXTEND = "native nativesdk"