blob: e734a215fd216c300a71255ba35cdca81e8ff15b [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Xlib: Compose data files for libx11"
2DESCRIPTION = "This package provides the compose data files for libx11."
3
4python () {
5 if bb.utils.contains('DISTRO_FEATURES', 'x11', True, False, d):
6 raise bb.parse.SkipRecipe("libx11-compose-data is incompatible with x11 distro feature, use libx11 instead.")
7}
8
9require xorg-lib-common.inc
10
11LICENSE = "MIT & BSD-1-Clause & HPND & HPND-sell-variant & ISC"
12LIC_FILES_CHKSUM = "file://COPYING;md5=1d49cdd2b386c5db11ec636d680b7116"
13
14XORG_PN = "libX11"
15
16SRC_URI += "file://0001-Drop-x11-dependencies.patch \
17 "
18
19SRC_URI[sha256sum] = "e31565c84006b6b8e01dc9399c806085739710bc2db2e0930f1511ed9d6585bd"
20
21REQUIRED_DISTRO_FEATURES = ""
22
23EXTRA_OECONF += "--disable-xkb"
24
25do_compile() {
26 oe_runmake -C nls
27}
28
29do_install() {
30 oe_runmake DESTDIR=${D} -C nls install
31}
32
33PACKAGES = "${PN}"
34
35FILES:${PN} = "${datadir}/X11/locale ${libdir}/X11/locale"