blob: 279d6c33dc1f5e1e87c7bcb52587473aedd5181a [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Xdamage: X Damage extension library"
2
3DESCRIPTION = "'Damage' is a term that describes changes make to pixel \
4contents of windows and pixmaps. Damage accumulates as drawing occurs \
5in the drawable. Each drawing operation 'damages' one or more \
6rectangular areas within the drawable. The rectangles are guaranteed to \
7include the set of pixels modified by each operation, but may include \
8significantly more than just those pixels. The DAMAGE extension allows \
9applications to either receive the raw rectangles as a stream of events, \
10or to have them partially processed within the X server to reduce the \
11amount of data transmitted as well as reduce the processing latency once \
12the repaint operation has started."
13
14require xorg-lib-common.inc
15
16LICENSE = "MIT"
17LIC_FILES_CHKSUM = "file://COPYING;md5=9fe101f30dd24134cf43146863241868"
18
19DEPENDS += "virtual/libx11 xorgproto libxfixes"
20PROVIDES = "xdamage"
21
22PE = "1"
23
24XORG_PN = "libXdamage"
25
26SRC_URI[sha256sum] = "52733c1f5262fca35f64e7d5060c6fcd81a880ba8e1e65c9621cf0727afb5d11"
27
28BBCLASSEXTEND = "native nativesdk"