blob: bf5d2d6721668e2840f44dc4c90acf8f5876b209 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "XDMCP: X Display Manager Control Protocol library"
2
3DESCRIPTION = "The purpose of the X Display Manager Control Protocol \
4(XDMCP) is to provide a uniform mechanism for an autonomous display to \
5request login service from a remote host. An X terminal (screen, \
6keyboard, mouse, processor, network interface) is a prime example of an \
7autonomous display."
8
9require xorg-lib-common.inc
10
11inherit gettext
12
13LICENSE = "MIT"
14LIC_FILES_CHKSUM = "file://COPYING;md5=d559fb26e129626022e052a5e6e0e123"
15
16DEPENDS += "xorgproto"
17PROVIDES = "xdmcp"
18
19PE = "1"
20
21XORG_PN = "libXdmcp"
22
23BBCLASSEXTEND = "native nativesdk"
24
25SRC_URI[sha256sum] = "2dce5cc317f8f0b484ec347d87d81d552cdbebb178bd13c5d8193b6b7cd6ad00"
26
27PACKAGECONFIG ??= ""
28PACKAGECONFIG[arc4] = "ac_cv_lib_bsd_arc4random_buf=yes,ac_cv_lib_bsd_arc4random_buf=no,libbsd"