blob: ad126d209267331780eb7e420bb01f702fd9a5a4 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "XFt: X FreeType libary"
2
3DESCRIPTION = "Xft was designed to provide good support for scalable \
4fonts, and to do so efficiently. Unlike the core fonts system, it \
5supports features such as anti-aliasing and sub-pixel rasterisation. \
6Perhaps more importantly, it gives applications full control over the \
7way glyphs are rendered, making fine typesetting and WYSIWIG display \
8possible. Finally, it allows applications to use fonts that are not \
9installed system-wide for displaying documents with embedded fonts. Xft \
10is not compatible with the core fonts system: usage of Xft requires \
11fairly extensive changes to toolkits (user-interface libraries)."
12
13require xorg-lib-common.inc
14
15LICENSE = "MIT"
16LIC_FILES_CHKSUM = "file://COPYING;md5=90b90b60eb30f65fc9c2673d7cf59e24"
17
18DEPENDS += "virtual/libx11 libxrender freetype fontconfig"
19PROVIDES = "xft"
20
21PE = "1"
22
23SRC_URI[sha256sum] = "79f0b37c45007381c371a790c2754644ad955166dbf2a48e3625032e9bdd4f71"
24
25XORG_PN = "libXft"
26
27BBCLASSEXTEND = "native nativesdk"
28
29python populate_packages:prepend () {
30 if d.getVar('DEBIAN_NAMES'):
31 d.setVar('PKG:${PN}', '${MLPREFIX}libxft2')
32}